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See the way Personalized Products for Magento 2 extension works.

Guide for Personalized Products for Magento
2

Make your products customizable to meet the interests of a wider audience. Customers design and
purchase the product that suits them with Magento Product Customization extension - you get your
conversion rates driven higher.

Let shoppers add custom text, images, and clipart to design their product
Allow them to choose text formatting like alignment, font size, effects, type, font color, text
effects, etc.
Show specific design messages on customizable products to make users aware of this option
Allow customers to preview and download the design files directly from their accounts

To activate this product you need a key. You can get it by contacting our support center
https://support.amasty.com/

Extension Configuration

After buying the extension you can go to Magento backend and configure the extension from here.

https://personalized-products-m2.magento-demo.amasty.com/admin/admin/system_config/edit/section/personalizedrich/
https://support.amasty.com/
https://amasty.com
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You can access your serial key from the “My Account” dashboard and enter it here to activate the
module.

The below functionality allows the admin to enable or disable the Personalized Products extension on
the frontend.

After that, product page with personalization features enabled.

https://amasty.com
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Personalization Area settings

Using this setting the admin can define the area within which a customer will be able to apply all
personalization features. Outside this area, personalization will not be possible.

Set this to “No” if you do not want any restriction on design area inside the product image.

General Configuration

https://amasty.com
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Customize Personalization button

Using this feature the admin can customize the personalization button label to something like
“Personalize Now”, “Personalize this product” etc.

Setting Personalization Mode

This setting allows the admin to display the personalization features directly on the product page or in
the form of a pop-up.

Specific Personalization Features

Navigate to Milople Extension → Catalog will open the following grid with all store products listed.

Clicking on “Edit” will allow the admin to set personalization features for this specific product.

https://amasty.com
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Customization Allowing

Let us take a t-shirt for example. The admin can allow the customer to add design to various sides of
the t-shirt (front, back, right sleeve, left sleeve). The admin can display this option (available sides for
customization) on the frontend to the customer. This can be done by clicking on the desired product
in catalogue section and navigating to “Images and Videos” tab. There the admin can create new
templates (defining sides of a product) and set restriction area for design. These templates, defining
the sides of the product available for customization will appear on the frontend alongside the product
image.

https://amasty.com
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Text and Font Settings

The store admin can allow the user to enter text into the design area for personalization.

Also, text formatting with google fonts can be allowed. The admin can choose, which google fonts will
be available to the customer for text formatting.

The store admin can navigate to Milople Extensions → Manage Fonts and find a grid where all
created fonts are listed. The status and names of these existing fonts can be edited or new fonts can
be added using the “Add New Fonts” button.

Clicking on “Select → Edit” for an existing font or clicking on “Add New Fonts” will redirect to the
page shown below. “Select → Delete” will delete the selected font.

https://amasty.com
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The admin can set an amount in this field. This amount will be charged for each text that will be
added by the customer into the design area. Leaving this empty would make it free for the customers
to add text.

Image and clipart settings

The admin can allow the customer to upload images and clipart into the design area for the purpose
of personalization.

Setting these to “No” will not allow the customer to personalize the product with images and clipart.

The admin can set an amount in this field. This amount will be charged for each image that will be
added by the customer into the design area. Leaving this empty would make it free for the customers
to add images.

https://amasty.com
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Raw Images Downloading

This extension allows the admin to download the image of original size and quality that was uploaded
by the customer into the canvas for the purpose of personalization.

“Fit to Canvas” settings

The image uploaded by the customer for personalization will fit to the exact size of the canvas.
Setting this to “No” will disallow this functionality. In that case, the image size will remain same as
original irrespective of size of the canvas or size of the design area available.

Manage Clipart Image

By navigating to Milople Extensions → Manage Clipart image, the admin will be able to find grid
shown below. Here all the created clipart images would be listed. New clipart images can also be
added using “Add New image” button.

Clicking on “Select → Edit” for an existing image or clicking on “Add New Image” will redirect to
the page shown below.

https://amasty.com
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Manage Clipart category

By navigating to Milople Extensions → Manage Clipart category, the admin will be able to find
grid shown below. Here all the created clipart categories would be listed. New categories can also be
added using “Add New Category” button.

Clicking on “Select → Edit” for an existing category or clicking on “Add New Category” will
redirect to the page shown below. “Select → Delete” will delete the selected category.

https://amasty.com
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All the clipart images added in “Manage Clipart Image” section, would be listed down as shown
below. From here, the admin can select desired images and click on “Save category”. This will
assign those images under this particular clipart category.

Predefined template settings

This is available only in the RICH version.

https://amasty.com
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The “Template” functionality allows the customer to add predefined templates on the design area and
also to edit the existing template.

Templates Adding

The admin can create templates on the back end through Catalog→Products. Click on “Edit” for the
desired product, navigate to Images and Videos tab and click on “edit” icon. A model will be open as
shown in the below image.

Creating New Template

Admin can create new template by clicking on Add New Template.

https://amasty.com
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Assigning Templates to Front End

After saving the template, admin can navigate to home by clicking on Home button. There the
preview of the created template will be available and that can be assigned to the frontend by clicking
on the checkbox and saving it.

https://amasty.com
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Copying Existing Templates

Admin can copy templates by clicking on Copy Existing Templates. All the templates related to the
product will appear. The selected templates can be copied by clicking on Add Existing Templates.

https://amasty.com
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Deleting Templates

The admin can delete the templates by clicking on delete button. The selected templates will be
deleted.

https://amasty.com
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Name and Number

The “Name and number” functionality allows the customer to add name and/or number in the
design area.

Product specific Name and Number Settings

Name and Number for specific side of a product

https://amasty.com
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The admin can also assign Name and Number only to specific side of a product. The assignment of
Name and Number for a particular side can be achieved by clicking on the desired product in
catalogue section and then navigating to Images and Videos tab. The admin can find Name and
Number along with options like Base, Small, Thumbnail etc.

The first image will be assigned the role of Name & Number by default.

Name Settings

Admin can assign 'Name and Number' feature to all products or to a specific group only.

Name field for Specific Products

The admin also has the flexibility to allow the Name field on specific products only. This can be done
by editing the desired product in Catalog section and navigating to Personalized Name and Number.

https://amasty.com
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Number Settings

The Number field will appear for all the products with the title given in the label field.

Allowing Number field for Specific Products

The admin can allow Number field to only specific products. This can be done by editing the desired
product in the Catalog section and navigating to Personalized Name and Number.

https://amasty.com
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Size Settings

Size option will appear with the title given in the Label for Size Box field and values specified in the
Size box Values field.

Size option for Specific Products

The admin can allow Size option to specific products only. This can be done by editing the desired
product in Catalog section and navigating to Personalized Name and Number.

https://amasty.com
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Adding Size Values

The admin can provide different sizes for products by adding the values to Select Size attribute.

Quote

The “Quote” functionality allows the customer to add predefined quotes in the design area.

https://amasty.com
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Quote Settings

The Admin can allow adding Quote to all products or to selected products only.

Quote functionality can be assigned to specific products in Catalog section, by selecting the desired
product and navigating to Personalized products tab.

Price of Quote

This setting allows the admin to charge a price for the quote that user adds into the design.

Mange Quote Categories

By navigating to Milople Extensions → Manage Quote Categories, the admin will be able to find
grid shown below. Here all the created quote categories would be listed. New categories can also be
added using “Add New Category” button.

https://amasty.com
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Manage Quotes

By navigating to Milople Extensions → Manage Quotes, the admin will be able to find grid shown
below. Here all the created clipart images would be listed. New clipart images can also be added
using “Add New Quote” button.

https://amasty.com
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Product Personalization by Customer

Choosing sides

The customer can choose the sides in which he/she wants to design.

Adding Text

In this section, the customer can add a text in the design area. Text style, text effect can also be
edited.

https://amasty.com
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Uploading images

The user can upload images into the design area.

https://amasty.com
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Uploading Clipart

Adding Quotes

https://amasty.com
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Adding Name and Number

https://amasty.com
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Find out how to install the Personalized Products extension for Magento 2 via Composer.
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